Home > App-V > App-V The solution in Knowledge Base article 959459 did not work. What did I do wrong?

App-V The solution in Knowledge Base article 959459 did not work. What did I do wrong?


Do you have the App-V 4.5 management server installed on the same server as your SQL server? Are you getting the following error every time you try to start the App-V Management Server service?

System error 1075 has occurred.

The dependency service does not exist or has been marked for deletion.

This may also occur frequently after implementing changes outlined in KB 959459.

In KB959459, there are instructions to configure a service dependency for the AppVirtServer service registry key.

When you add a REG_MULTI_SZ value named DependOnService to the key and put in MSSQLSERVER as the default, it is assuming that you are working with a default instance of SQL Server instead of a named instance.

However, if you are using a named instance, the SQL Server service entry will not be named MSSQLSERVER, therefore this dependency will be invalidated upon startup and this message will display.

To fix this, instead of placing the value MSSQLSERVER in the DependOnService key, place the name of the instance registered (i.e. MSSQL$VIRT or MSSQL$APPV, etc.)

This will require a full reboot of the server to take effect.

Steve Thomas

  1. No comments yet.
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: